Connecting to themanadrain.com without www won't work

When I try to connect to themanadrain.com, without putting www. first, it gives me this screen. Anyone having this issue too?

I'm on a Mac, Google Chrome.

0_1561905530856_cf64a3ec-8bc4-4db8-aae2-2a63c433086a-image.png

It works for me, but seems like it's on the old design. I guess it doesn't just redirect to the main site (as it normally does), but it's the old site.

The website without www is always different than the website with www, but usually when someone get a domain, they usually get the same domain without www just so that this link also access the same website, but it usually only redirect to the real website. In this case, the link without www has the old website.

I had the same problem for a few days. I couldn’t access the site with my phone but could with my computer. Eventually I just followed a link through a google search for themanadrain and it corrected itself.

I believe (but can't verify) that this is an issue with cached redirects ... essentially, you visited the site at some point when it was down (it was down a few nights ago). The site redirected you to an error page, and your browser stored that redirect so that next time it would happen faster, it never "unlearned" the redirect, even after the site was fixed. Since your browser saves these redirect rules on a per-url basis, that explains why the url www.themanadrain.com might be broken, when the url www.themanadrain.com/some/specific/post works. It also explains why a url might work for one person but not another, and on your phone but not your desktop, as each browser has a different redirect cache.

You can verify this by trying to visit the bad url in an incognito/private browser, which doesn't save anything in the cache.

If that's the problem, then clearing your browser cache/browser redirect cache should solve it (different process for different browsers, should be easily searchable. If that's NOT the problem, then something else is up, so let me know!

Ultimately this is still TMD's "fault" because you should be able to define an expiration for a redirect, and it sounds like the site is treating it as permanent or long-lasting when it shouldn't be, but this is probably pretty deep in the forum software and might be tough to fix.

I know I just gave you WAY more information than anyone asked for, but I'm an engineer so that's what I do <3.

I feel like this is the equivalent of when someone asks "hey do you think Shenanigans is good against shops?" and I post a 6 paragraph treatise on how to change your manabase to support a three-tiered counterstrategy.

last edited by Brass Man

@brass-man

Keeping us safe from Chinese hackers and URL redirects. It’s a thankless job

@brass-man That was it. Just a cmd + shift + R (on Windows it's what, Shift + F5? Alt + F5? I don't remember) did the trick. Sorry to trouble you because of such an easy-to-fix issue 😛

@fsecco you apologize like I don't live for the times when I can babble on about a topic I'm mildly informed about ❤ 🤣

  • 7
    Posts
  • 836
    Views